URL Networks

Cisco 857/877 ADSL Configuration

You are here: Help Routers Cisco 857/877 ADSL Configuration


If you have a Cisco IOS style router then this will help you get the basic configuration configured to get online.

ADSL Config

You should change the following items in the configuration listed below, if you copy and paste this configuration it will set the router to be on 192.168.0.1, once connected to the internet you should conduct a security scan to make sure your router is not open to the world:
  • ISP_USERNAME – The username as supplied by your ISP
  • ISP_PASSWORD – The password supplied by your ISP
  • MY_ADMIN_PASSWORD – The administration password you would like on your router
line vty 0 4
password 0 MY_ADMIN_PASSWORD
login

interface ATM0
no ip address
no atm ilmi-keepalive
pvc 8/35
encapsulation aal5snap
protocol ppp dialer
dialer pool-member 1
!
dsl noise-margin 3
dsl bitswap both

interface Vlan1
ip address 192.168.0.1 255.255.255.0
ip nat inside
ip virtual-reassembly

interface Dialer1
ip address negotiated
ip access-group FW in
ip nat outside
ip virtual-reassembly
encapsulation ppp
dialer pool 1
dialer idle-timeout 0
dialer-group 1
no cdp enable
ppp chap hostname ISP_USERNAME
ppp chap password 0 ISP_PASSWORD
ppp ipcp route default

no ip http server
no ip http secure-server
ip dns server

no ip nat service sip tcp port 5060
no ip nat service sip udp port 5060

ip access-list extended FW
deny ip any any

ip nat inside source list 1 interface Dialer1 overload

access-list 1 permit 192.168.0.0 0.0.255.255